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1 Põhiprogramm ’Visitors’ 

 

Kasutajaliidese legend: 

1) Peamenüü ja tööriistariba. 

2) Külalisi objektil. 

3) Tabel külastajate andmete ja kellaaegadega. 

4) Arvutiga ühendatud kaardilugejate info ja staatus. 

Sisselogimise aken: 
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1.1 Peamenüü kirjeldus 

1.1.1 ‘File’ alammenüü 

 

1) File → Export to… – ekspordib ekraanil olevate külastajate anded valitud formaati. See 

käsklus on nähtav õiguste olemasolul. 

2) File → Open Visitors.ini – avab “Visitors.ini” faili seadete muutmiseks või parandamiseks. 

See käsklus on nähtav õiguste olemasolul. 

3) File → Log off – logib kasutaja välja. 

4) File → Print Page setup – väljatrüki seadistus ( litsentsi ja õiguste olemasolul ). 

5) File → Font Size → Increase – suurendab tabeli fonti. 

6) File → Font Size → Decrease – vähendab tabeli fonti. 

7) File → Import Permissions from csv – eelregistreerimis andmete import csv failist. See 

käsklus on nähtav õiguste olemasolul. 

8) File → Import Blacklist from csv – keelatud isikute andmete import csv failist. See käsklus 

on nähtav õiguste olemasolul. 

9) File → Database → Working – kuvab töös olevat andmebaasi. See käsklus on nähtav 

õiguste olemasolul. Vt. täpsemalt Arhiivi andmete vaatamine. 

10) File → Database → Archive – võimalus kuvada arhiivi andmebaasi. See käsklus on nähtav 

õiguste olemasolul. Vt. täpsemalt Arhiivi andmete vaatamine. 

11) File → Exit – väljub programmist. 
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1.1.2 ‘Options’ alammenüü 

 

1.1.2.1 Kaardilugejate seadistamine 

Options → Readers – Avab kaardilugejate häälestamise akna. See käsklus ja nupp on 

nähtav õiguste olemasolul. Sama käsklust saab anda ka vajutades allolevale nupule: 

 

Nupule vajutades avaneb alljärgnev aken: 

 
Siit saate valida arvutiga ühendatud MRTD, RFID kaardilugeja ja Eesti ID kaardilugeja 

millega soovite, et programm töötaks. Peale valikut vajutage nuppu ’Save’ ja 

taaskäivitage programm. Vastav teade kuvatakse ka kaardilugejate staatuse osas: 

http://www.telegrupp.ee/
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1.1.2.2 Kasutajate haldus ja paroolide muutmine 

Options → User Accounts – Siit saate luua uusi kasutajaid ja määrata kasutajatele parooli 

ning olemasolevate kasutajate paroole muuta ja kasutajaid kustutada. Uue andmebaasiga 

on vaikimisi olemas kaks kasutajat – Admin ja Valvur. Vaikimisi Admin parool on “1” (ilma 

jutumärkideta) ja Valvur parool on „2“. See käsklus ja nupp on nähtav õiguste olemasolul. 

Sama käsklust saab anda ka vajutades allolevale nupule: 

 

 

Nupule vajutades avaneb alljärgnev aken: 

 

Akna ülemises sektsioonis saab luua ja kustutada kasutajaid ning alumises osas muuta 

olemasolevate kasutajate paroole. 
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1.1.2.2.1 Uue kasutaja loomine 

Uue kasutaja loomiseks sisestage uus kasutajanimi ( max. 10 tähemärki ) 

 

Ja vajutage nuppu ’Create’ -> luuakse uus kasutaja. 

 

Järgmiseks valige alumisest loetelust kasutajanimi mille olete just loonud ning sisestage 

kasutaja parool lahtritesse ’New Password’ ja ’Confirm Password’ ( ’Old Password’ jääb 

tühjaks kuna sellel kasutajal varem parooli ei olnud ): 

 

Vajutage ’OK’ ja kasutajale on uus parool määratud. Järgmiseks tuleb kasutajale määrata 

õigused ( vaikimisi kõik õigused puuduvad ). Täpsemalt vt. Kasutajate õiguste määramine. 
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1.1.2.2.2 Kasutajate kustutamine 

Kasutaja kustutamiseks vali akna ülemises osas kasutaja keda soovid kustutada: 

 

Ja vajutage nuppu ’Delete’ -> valitud kasutaja kustutatakse koos kõikide õigustega. 

 

NB! Ettevaatust, et te ei kustutaks kõiki Admin õigustega kasutajaid. Vastasel korral 

pole võimalik teil süsteemi seadistada. 

Admin parooli unustades või kõikide Admin õigustega kasutajate kustutades pöörduge 

Telegrupp AS poole. 

 

1.1.2.2.3 Paroolide muutmine 

Olemasolevate kasutajate paroolide muutmiseks valige alumisest loetelust kasutajanimi 

kelle parooli soovite muuta: 

 

Sisestage vana parool ja kaks korda uus parool ( ’Old Password’, ’New Password’ ja 

’Confirm Password’ ) ning vajutage ’OK’ -> valitud kasutaja parool on muudetud. 
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10    Visitors 

Telegrupp AS    

 www.telegrupp.ee  

Vea korral kuvatakse vastav veateade: 

 

 

Vana parool ei ole õige. 

 

 

Uued paroolid ei kattu. Sisesta uued paroolid uuesti. 
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1.1.2.3 Kasutajate õiguste määramine 

Options → User Premissions – Kasutajatele õiguste andmine. See käsklus on nähtav 

vastavate õiguste olemasolul. 

 

 
 

Valige millised õigused funktsioonid ja nupud on valitud kasutajale vajalikud ning vajutage 

’Ok’ andmete salvestamiseks. Järgmisel kasutaja sisselogimisel on nähtavad ainult talle 

lubatud toimingud. 

 

Uuel loodud kasutajal puuduvad vaikimisi kõik õigused ja need on vaja määrata kohe 

peale uue kasutaja loomist. 
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Kasutajaõiguste kirjeldused: 

Export – andmete salvestamine etteantud formaati ( menüü ) 

Open Visitors.ini – Tarkvara seadistus faili avamine 

Readers – kaardilugejate häälestus ( menüü ja nupp ) 

Passwords – paroolide muutmine ( menüü ) 

Delete from DB – vanade sündmuste kustutamine andmebaasist ( menüü ja nupp ) 

Backup Database – andmebaasi varukoopia tekitamine ( menüü ja nupp ) 

Restore Database – andmebaasi varukoopia taastamine ( menüü ja nupp ) 

Open Backup Folder – varukoopia kausta avamine ( menüü ) 

Open Restore Folder – taastuskoopia kausta avamine ( menüü ) 

Filter and Database menu– andmete päring/filtreerimine ( nupp ) + arhiivi vaatamine 

Filter + - jooksvate andmete kuvamine/peitmine põhiaknas ( nupp ) 

Print page Setup – väljatrüki seadistamine ( menüü ) 

Print – andmete printimine ( nupp ) 

Visitors Sheet – tabel külastajate andmete ja kellaaegadega 

Premissions Sheet – eelregistreerimiste tabel ja andmete sisestamine 

Blacklist Sheet – keelatud isikute tabel ja andmete sisestamine 

Valvur Premissions Menu – kasutaja ’Valvur’ õiguste andmine ( menüü ) 

New Visitor Button – käsitsi uue külastaja lisamine ilma RFID kaardita ( nupp ) 

Visitors Quick Customization – külastajate tabeli tulpade seadistamine 

Premis Quick Customization – eelregistreerimiste tabeli tulpade seadistamine 

Blacklist Quick Customization – keelatud isikute tabeli tulpade seadistamine 

Visitors Sheet Double Click – ilma RFID kaardita külastajate väljaregistreerimine 

Premis Sheet Double Click – eelregistreeringute kustutamine 

Blacklist Sheet Double Click – keelatud isikute kustutamine 

Import Permissions from csv – eelregistreeringute import csv failist 

Import Blacklist from csv – keelatud isikute import csv failist 

http://www.telegrupp.ee/
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1.1.3 ’Services’ alammenüü 

 

1.1.3.1 Varukoopia tekitamine 

Service → Backup Database… – Tekitab külastajate andmebaasist varukoopia 

eelmääratud asukohta serveri kõvakettal. See käsklus ja nupp on nähtav õiguste 

olemasolul. Sama käsklust saab anda ka vajutades allolevale nupule: 

 

Nuppu vajutades teostatakse alljärgnevad toimingud: 

• Tehakse jooksvast andmebaasist serveri ’backup’ kataloogi varukoopia fail: 

Visitors_<tänane_kuupäev>_<kellaaeg>.fbk 

 

1.1.3.2 Varukoopia taastamine 

Service → Restore Database… – Taastab külastajate registreerimise andmebaasi 

varasemalt tehtud varukoopiast. See käsklus ja nupp on nähtav õiguste olemasolul. Sama 

käsklust saab anda ka vajutades allolevale nupule: 

 

Nuppu vajutades teostatakse alljärgnevad toimingud: 

 

• Tehakse jooksvast andmebaasist serveri ’backup’ kataloogi varukoopia fail: 

Visitors_<tänane_kuupäev>_<kellaaeg>.fbk ( juhuks kui midagi peaks rikki minema 

on võimalik jooksev andmebaas taastada ) 

http://www.telegrupp.ee/
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• Avaneb varukoopia valimise aken: 

 

• Siit tuleb valida varukoopia fail millest soovitakse varukoopia taastada ning 

vajutada nuppu ’Open’. 

• Kui antud varukoopia on Visitors 3.9 versiooni oma siis taastatakse antud 

varukoopia. 

NB! Peab meeles pidama, et andmebaasi taastades võetakse kasutusele ka vanas 

andmebaasis olnud kasutajad ja paroolid. 

• Kui valitud fail ei ole Visitors 3.9 versiooni varukoopia või on mingi muu 

andmebaasi fail siis kuvatakse alljärgnev veateade ja varukoopiat ei taastata: 

 

Kui te olete veendunud, et tegemist on Visitors andmebaasi varasema versiooniga 

siis palun pöörduge Telegrupp AS poole, et saada juhiseid kuidas varasemat 

Visitors andmebaasi saab uuendada 3.9 versioonile. 
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1.1.3.3 Varukoopia kataloogid 

Service → Open Backup Folder ja Open Restore Folder – avab vastava varukoopia kausta. 

Need käsklused on nähtavad õiguste olemasolul. 

 

’backup’ ja ’restore’ kataloogid määratakse tarkvara paigalduse käigus. Hiljem on võimalik 

neid muuta failist Visitors.ini. Seadistuste tegemiseks otse Visitors.ini failist konsulteerige 

ennem Telegrupp AS-ga. 

 

1.1.4 Tööriistariba nuppude kirjeldus 

 

– Andmete kustutamine andmebaasist. Vastava õiguse olemasolul on võimalik baasis 

kustutada määratud kuupäevale eelnevad sündmused. 

Nupule vajutades avaneb alljärgnev aken: 

 
 Rippmenüüst valitud kuupäevast varasemad kirjed kustutatakse. 

’Visitors’ tabelist  

kustutatakse kõik külastajad määratud kuupäevast ettepoole, kes on hoonest lahkunud 

( välja registreeritud ). 

’Premissions’ tabelist  

kustutatakse kõik eelregistreeringus määratud kuupäevast ettepoole, kelle registreerimis 

lõpukuupäev on möödunud ( nt. kui külastajale on antud eelregistreering 01.01.2013 – 

31.12.2013 ja kuupäevaks valida 30.12.2013, siis antut eelregistreeringut ei kustutata 

kuna lõppkuupäev pole veel kätte jõudnud ). 

http://www.telegrupp.ee/
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– Vastava õiguse olemasolul avab sündmuste filtri. vt. Töötamine filtriga ( päringud ) 

 

– Vastava õiguse olemasolul valib kõikide sündmuste ja tagastamata kaartide 

vaate vahel. 

 

– Vastava õiguse olemasolul uue külastaja registreerimine ilma RFID kaardita.  

 

1.1.5 Kaardilugejate staatuse riba 

Arvutiga ühendatud kaardilugejate info ja staatuse kirjeldus: 

1) Kaardilugeja pole seadistatud: 

 
2) Kaardilugeja pole ühendatud: 

 
3) Kaardilugeja on ühendatud aga kaarti pole sisestatud: 

 

4) Kaardilugeja on ühendatud ja kaart on sisestatud: 

 

http://www.telegrupp.ee/
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1.2 Külastajate ja eelregistreeringute andmete tabel 

1.2.1 Tabeli tulpade valik 

 

 

– Vajutades tabeli nurka saab valida millised andmed ( tulbad ) on ekraanil nähtavad. 

1.2.2 Andmete sorteerimine / järjestus 

– Andmete sorteerimiseks/järjestamiseks vajutage vastava tulba päisel. 

1.2.3 Andmete filtreerimine põhiaknas 

 

– Andmete filtreerimiseks põhiaknas vajutage tulba kõrval olevale nupule ja valige andmed mida 

soovite näha. Filtri eemaldamiseks vajutage all olevale punasele nupule. 
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2 Töötamine programmiga 

2.1 Külaliste registreerimine ja külastajakaartide väljastamine 

2.1.1 Automaatne režiim 

 

Tarkvara töötab automaatses režiimis kui mõlemad RFID ( läbipääsukaardilugeja ) ja ID 

kaardilugejad on ühendatud arvutiga ( lisavõimalusena saab ühendada ka 3M CR100 MRTD 

dokumendi lugeja ). Kui näidata RFID kaarti lugejale avaneb „New visitor“ ( uus külastaja ) aken ja 

automaatselt loetakse maha läbipääsu kaardi number, mis külalisele väljastatakse.  

 

http://www.telegrupp.ee/
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Kui peale seda sisestada ID kaardilugejasse ID kaart, loetakse sealt maha külastaja isikukood, 

perekonnanimi ja eesnimi.  

Kui arvutiga on ühendatud 3M CR100 lugeja võib sealt läbi tõmmata MRTZ koodiga dokumendi. 

MRTZ koodiga dokumendist loetakse maha dokumendi tüüp, dokumendi nr., perekonnanimi ja 

eesnimi. 

Kui ID kaarti ei sisestata on võimalus käsitsi täita kõik andmed: dokumendi tüüp, isikukood või 

dokumendi number, perekonnanimi ja eesnimi. 

Samal ajal võrreldakse sisestatud isikukoodi või dokumendi nr. keelatud isikute ja eelregistreeritud 

andmetega ning kuupäeva vahemikuga. Kui isik on keelatud isikute nimekirjas kuvatakse vastav 

kirje ja ’Kelle juurde’ andmetesse kirjutatakse automaatselt ’Keelatud’. Kui antud kuupäeval 

eelregistreering puudub, siis kuvatakse vastav teade kui aga eelregistreering on olemas, siis 

kuvatakse vastav tekst ja olemasolul ka eelregistreeritud lisainfo ( nt. auto numbrid või kelle 

juurde, märkused ): 
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Peale seda on võimalik käsitsi täita lisalahter auto number või numbri olemasolul teha auto 

numbril topelt-klõps ja andmed täidetakse automaatselt. 

Igal registreeringul on ka vabalt täidetav märkuste lahter. 

 

Kui lahtrid täidetud, tuleb info kinnitada vajutades „Ok“ või kaks korda „Enter“ klahvi.  

Peale seda on külastaja andmed nähtavad põhiaknas koos kaardi väljastamise kuupäeva ja 

kellaajaga ja külastaja on sisse registreeritud : 

 

Kui külastaja tagastab külastajakaardi on vajalik seda uuesti näidata korra RFID kaardilugejale. 

Selle toiminguga registreeritakse kaardi tagastus aeg ja eemaldatakse külastaja põhiakna loetelust.  

http://www.telegrupp.ee/
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2.1.2 Pool-automaatne režiim 

 

Külastajaid on võimalik registreerida ka ilma töötava kaardilugejata. Vastava õiguse olemasolul 

saab uut külastajat registreerida vajutades „New visitor“ nuppu tööriistaribal.  

 

 

 

Kui seda nuppu vajutada avaneb „New visitor“ aken ja tekib võimalus külastajakaardi number 

käsitsi sisestada.  

 

 

Ülejäänud külastaja info on võimalik saada ID kaardilugejast, 3M CR100 dokumendi lugejast, kui 

see on arvutiga ühendatud või täita kõik andmed käsitsi.  
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Kui külastaja tagastab läbipääsukaardi ja RFID kaardilugeja pole arvutiga ühendatud, tuleb teha 

hiirega topelt-klõps põhiakna selle külastaja tabeli rea peal.  

 
Peale seda kuvatakse teile kinnitusaken: 

 

Kui olete kindel, siis vajutage ’Yes’ ja sellega registreeritakse külalise käsitsi kaardi tagastuse 

kuupäev ja kellaaeg ning kirje eemaldatakse põhiakna loetelust. 
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2.2 Külastajate eelregistreerimine 

2.2.1 Eelregistreerimise lisamine 

Külastajate eelregistreerimiseks minge ’Premissions’ lehele: 

 

Uue registreeringu sisestamiseks vajutage nuppu: 

 

ning peale seda avaneb teil alljärgnev aken: 

 

Siin on vajalik täita kogu eelregistreerimis info külastaja kohta. Eriti oluline on sisestada väga 

täpselt isikukood või dokumendi number, kuna selle alusel toimub kaardi väljastamisel 

andmete kontroll. Lubatud on sümbolid on numbrid ja tähed. 

Kui kõik andmed sisestatud siis, vajutage ’Ok’ ja antud isiku eelregistreering kuvatakse aknas: 

Kõik aegunud eelregistreeringud kustuvad aknast automaatselt. 
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2.2.2 Eelregistreerimise kustutamine 

Kui soovite mõnda eelregistreeringut käsitsi kustutada, siis tehke vastava rea peal hiirega  

’topelt klõps’ ja vajutage kinnitusaknal ’Yes’. 

2.2.3 Eelregistreeringute import csv failist. 

 

Eelregistreeringuid on võimalik importida csv failist. Faili näidise leiate ’Visitors\Tools’ kataloogist. 

Andmete importimiseks ( õiguste olemasolul ) valige menüüst File → Import Permisiions from 

csv  

Peale seda avaneb aken, otsige üles eelnevalt koostatud csv fail ning vajutage ’Open’ 

 

 

 

Kui csv fail on õigesti koostatud siis imporditakse kõik andmed Permissions ( Eelregistreeringute ) 

tabelisse. Andmed lisatakse alati varasematele juurde, eelnevaid registreeringuid ei kontrollita 

ega kustutata!  

http://www.telegrupp.ee/


 

 
                                                                                  

25    Visitors 

Telegrupp AS    

 www.telegrupp.ee  

Kui faili andmetes on viga ( mõni kohustuslik väli täitmata ) kuvatakse alljärgnev veateade: 

 

 

Vigase faili puhul andmeid ei impordita. Antud faili sisu tuleb üle kontrollida, kas kõik 

kohustuslikud andmeväljad on täidetud. 

 

Kui valitud CSV fail ei sisalda kohustuslikku esimest kahte rida ( vale faili formaat ) kuvatakse 

alljärgnev veateade: 

 

2.2.3.1 csv faili struktuur 

 

Faili näidise leiate ’Visitors\Tools’ kataloogist. Siin on kuvatud näidis faili sisu: 

 

 

Oluline on säilitada failis esimene ja teine rida. Kolmandast reast saab täita imporditavad andmed. 

Kohustuslikud väljad mida kindlasti peab täitma on tähistatud *. Nendeks on: 

Firma, Perekonnanimi, Eesnimi, Isikukood, Alates ja Kuni. 

 

Valikuliselt võib eelregistreeringusse lisada veel Kelle juurde ja Auto numbrid ja Märkused 

 

Kogu infot on võimalik lihtsalt töödelda Excelis. Failile tuleb peale andmete sisestamist teha ’save 

as csv’. 

http://www.telegrupp.ee/
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2.3 Keelatud isikud 

2.3.1 Keelatud isikute lisamine 

Keelatud isikute lisamiseks minge ’Blacklist’ lehele: 

 

Uue isiku sisestamiseks vajutage nuppu: 

 

ning peale seda avaneb teil alljärgnev aken: 

 

Siin on vajalik täita kogu info keelatud isiku kohta. Märkuste lahter on valikuline. Eriti oluline on 

sisestada väga täpselt isikukood või dokumendi number, kuna selle alusel toimub kaardi 

väljastamisel andmete kontroll. Lubatud on sümbolid on numbrid ja tähed. 

http://www.telegrupp.ee/
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Kui kõik andmed sisestatud siis, vajutage ’Ok’ ja antud isiku andmed kuvatakse aknas: 

 

2.3.2 Keelatud isiku kustutamine 

Kui soovite mõnda keelatud isikut käsitsi kustutada, siis tehke vastava rea peal hiirega  

’topelt klõps’ ja vajutage kinnitusaknal ’Yes’. 

2.3.3 Keelatud isikute andmete import csv failist. 

 

Keelatud isikuid on võimalik importida csv failist. Faili näidise leiate ’Visitors\Tools’ kataloogist. 

Andmete importimiseks ( õiguste olemasolul ) valige menüüst File → Import Blacklist from csv  

Peale seda avaneb aken, otsige üles eelnevalt koostatud csv fail ning vajutage ’Open’ 

 

 

 

http://www.telegrupp.ee/
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Kui csv fail on õigesti koostatud siis imporditakse kõik andmed Blacklist ( Keelatud isikute ) 

tabelisse. Andmed lisatakse alati varasematele juurde, eelnevaid andmeid ei kontrollita ega 

kustutata!  

Kui faili andmetes on viga ( mõni kohustuslik väli täitmata ) kuvatakse alljärgnev veateade: 

 

 

Vigase faili puhul andmeid ei impordita. Antud faili sisu tuleb üle kontrollida, kas kõik 

kohustuslikud andmeväljad on täidetud. 

 

Kui valitud CSV fail ei sisalda kohustuslikku esimest kahte rida ( vale faili formaat ) kuvatakse 

alljärgnev veateade: 

 

2.3.3.1 csv faili struktuur 

 

Faili näidise leiate ’Visitors\Tools’ kataloogist. Siin on kuvatud näidis faili sisu: 

 

 

Oluline on säilitada failis esimene ja teine rida. Kolmandast reast saab täita imporditavad andmed. 

Kohustuslikud väljad mida kindlasti peab täitma on tähistatud *. Nendeks on: 

Perekonnanimi, Eesnimi ja Isikukood. 

 

Valikuliselt võib lisada veel Märkused 

 

http://www.telegrupp.ee/
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Kogu infot on võimalik lihtsalt töödelda Excelis. Failile tuleb peale andmete sisestamist teha save 

as csv. 

 

 

http://www.telegrupp.ee/
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3 Raportid ja Export 

3.1 Töötamine filtriga ( päringud ) 

 

Filter on vajalik päringute ja raportite koostamiseks. Külastajate ajaloo päringu tegemiseks tuleb 

vajutada nuppu „Filter“: 

  

 

Peale seda avaneb uus „Filter“ aken:  

 

Andmete filtreerimist saab teha alljärgnevate 

kombinatsioonidega: 

• Kuupäev + dokumendi tüüp 

• Kuupäev + dokumendi number 

• Kuupäev + külalise eesnimi 

• Kuupäev + külalise perekonnanimi 

• Kuupäev + kaardi number 

• Kuupäev + auto number 

• Kuupäev + Riik 

• Kuupäev + Töökoht 

• Kuupäev ( sel juhul kuvatakse kõik 

andmed sel kuupäeval või vahemikus ) 

• Kuupäev + vabateksti otsing tulbast 

’Kelle juurde’ 

• Kuupäev + vabateksti otsing tulbast 

’Märkused’ 

http://www.telegrupp.ee/
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Näide: kui soovitakse raportit kõikide külastajate kohta ajavahemikus 06.11.2014 – 01.12.2014 kes 

kasutasid ID kaarti, tuleks täita filtri aken alljärgnevalt ja vajutada nuppu „Run Report“: 

 

Filter aknas kuvatakse leitud külastajate arv ’Külastajaid kokku:’ 

 

Filtreeritud andmed kuvatakse põhiaknas vastavalt filtrile: 

 
 

http://www.telegrupp.ee/
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3.2 Andmete export 

Peale andmete filtreerimist on võimalik need andmed eksportida eraldi faili klikkides menüüs  

File → Export to… : 

 

Eksportimisel saab valida nelja erineva formaadi vahel: Excel, Text, HTML ja XML. 

Valida koht kuhu andmed salvestada ja anda failile nimi: 

 

Pärast seda vajutada nuppu „Save“ ( Salvesta ). Raport salvestatakse valitud formaati ja küsitakse 

kas avada fail kohe: 

 

Kui vajutada „OK“ avatakse raport vastavas programmis. 

Eksporditakse alati need andmed mis on nähtavad põhiaknas! 

http://www.telegrupp.ee/
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3.3 Andmete printimine 

Kui teil on olemas Printimise litsents ja vastavad õigused on võimalik põhiaknas olevad andmed 

saata arvuti vaikimisi printerisse vajutades nuppu: 

 

Prinditakse alati andmed mis on nähtavad põhiaknas! 

 

Näidis väljatrükk: 

 

http://www.telegrupp.ee/
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3.4 Arhiivi andmete vaatamine  

Arhiveeritud andmeid saab vaadata vastavate õiguste olemasolul. Kui õigused on olemas vali 

menüüst: 

  File → Database → Archive : 

 

Avaneb arhiivi faili valimise aken, valige arhiivi fail ning vajutage ’Open’; 

 

Kui valitud arhiiv oli Visitors 3.9 versiooni oma kuvatakse teie arhiivi andmed: 

 

Üleval akna päises näidatakse, et tegemist on arhiivi andmebaasiga ja nähtavale jäävad 

ainult ’Filtri’ nupud päringute tegemiseks, printimine ja andmete export. 

http://www.telegrupp.ee/
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Kui olete arhiiviga töö lõpetanud siis tagasi töös oleva andmebaasi juurde naasmiseks valige: 

File → Database → Working : 

 

Ning ühendust võetakse töös oleva andmebaasiga ning palutakse teil uuesti sisse logida: 

 

Kui valitud arhiivi fail ei ole Visitors 3.9 versiooni oma kuvatakse teile allolev veateade: 

 

Kui te olete veendunud, et tegemist on Visitors andmebaasi varasema versiooniga siis palun 

pöörduge Telegrupp AS poole, et saada juhiseid kuidas varasemat Visitors andmebaasi saab 

uuendada 3.9 versioonile. 

Arhiivi on võimalik vaadata ka kokkupakitud varukoopia failist. Selleks vali varukoopia fail 

kataloogist ’Visitors\Backup’ ( kõikide failide kuvamiseks vali failitüübiks All Files *.* ). Selle 

toimingu puhul pakitakse varukoopia lahti kataloogi ’Visitors\Restore’ ja kuvatakse antud arhiiv. 

 

 

http://www.telegrupp.ee/

